Nous avons mis à jour alt-mod-passagers vers la version 5.3.7-2 sur tous nos serveurs. Cette version concerne tous les serveurs utilisant CloudLinux 6/7, EasyApache 4 et httpd24.

Changelog:

alt-mod-passagers 5.3.7-2

  • ALMODP-112: Le gestionnaire Node.js est maintenant désactivé par défaut.
  • ALMODP-111: Les directives Passenger « PassengerFriendlyErrorPages » et « PassengerAppEnv » sont maintenant autorisées dans .htaccess.

Avec cette mise à jour, les directives, telles que PassengerFriendlyErrorPages et PassengerAppEnv, peuvent désormais être utilisées à partir du fichier .htaccess. Cela permet aux utilisateurs finaux de voir les erreurs de leur application pendant le processus de développement. Par exemple, si vous ajoutez le développement PassengerAppEnv ou les pages PassengerFriendlyError au fichier .htaccess sur la page de l'application et qu'une erreur se produit, une page d'erreur contenant des informations sur les erreurs s'est produite.

Page d'erreur alt-mod-passenger

C'est beaucoup plus pratique lors du développement et du débogage d'une application. Si les directives sont désactivées, vous verrez toujours une page d'erreur, mais aucune information ne sera affichée.

Page d'erreur alt-mod-passenger sans info

Ce mode sera utile une fois le processus de développement terminé, ce qui signifie qu'il convient au mode de production. Vous pouvez trouver plus d'informations sur PassengerFriendlyErrorPages et PassengerAppEnv.
 

Mettre à jour votre système

Tous les serveurs Nuagerie sont mis à jour automatiquement. Cependant, les commandes de mise à jour manuelle ont été incluses.


Pour les systèmes basés sur RPM:

Pour mettre à jour, lancez:

# yum update alt-mod-passenger

Pour installer, lancez:

# yum install alt-mod-passenger


Pour httpd24:

Pour mettre à jour, exécutez:

# yum update httpd24-alt-mod-passenger

Pour installer, exécutez:

# yum install httpd24-alt-mod-passenger


Pour EasyApache 4:

Pour mettre à jour, entrez:

$ yum update ea-apache24-mod-alt-passenger

Pour installer, entrez:

$ yum install ea-apache24-mod-alt-passenger


 mardi, février 5, 2019



« Retour